Bug #467

Ticket submit don't work if Priority type is private

Added by V G about 6 years ago. Updated over 5 years ago.

Status:Resolved Start date:17 Apr 2015
Priority:High Due date:
Assignee:- % Done:

0%

Category:-
Target version:-

Description

In submitticket.php file ticket priority type is hardcoded(TYPE_PUBLIC ) in following lines:
75: $_ticketPriorityContainer = kyTicketPriority::getAll()->filterByType(kyTicketPriority::TYPE_PUBLIC)->orderByDisplayOrder();
132: $_defaultPriorityID = kyTicketPriority::getAll()->filterByType(kyTicketStatus::TYPE_PUBLIC)->first()->getId();

As a result user will not be able to create ticket if you set priority type to Private in settings .

History

Updated by Mansi Wason about 6 years ago

Hi Vincentas,

This WHMCS integration is to make users interact with Kayako module.

While you create a ticket with "Private" visibility i.e. "Priorities are not visible to end users and only to staff users." , so ticket submit will not work.

So, this is not a bug. It is an intended functionality.

Thanks and Regards,
Mansi Wason

Updated by Mansi Wason over 5 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF